Canonicalin Ubuntu 14.04 LTS:n käyttäjille julkaisema Linux-ytimen päivitys saattoi joissain tapauksissa aiheuttaa kernel panic -virhetilanteen sekä estää Java-sovellusten käynnistämisen.

Canonicalin julkaisema kernelpäivitys korjasi Ubuntu 14.04 LTS:n käyttäjiltä L1 Terminal Fault -haavoittuvuuden sekä kaksi muuta tietoturva-aukkoa (CVE-2018-5390 ja CVE-2018-5391).

Haavoittuvuuksien hyväksikäyttö mahdollisti palvelunestohyökkäyksen käynnistämisen etäyhteyden avulla, Softpedia kirjoittaa.

Korjaus ei mennyt täysin putkeen, sillä sen tiedetään aiheuttaneen joillekin käyttäjille ei-toivottuja sivuvaikutuksia, kuten kernel panic -virhetilanteen sekä Java-sovellusten käynnistysongelmia.

Canonical julkaisi pian ongelmien ilmitulon jälkeen uuden päivityksen sekä pahoitteli aiemman korjauksen aiheuttamia ongelmia.

Mikäli käytössä on Ubuntu 14.04 LTS:n oletuskernel eli Linux 3.13, täytyy käyttäjän asentaa Ohjelmistopäivitykset-työkalun kautta ytimen uusin versio. Paketin nimi on linux-image 3.13.0-156.206. Tarkempia ohjeita on saatavilla täällä. Päivityksen asennuksen jälkeen on suositeltavaa käynnistää tietokone uudelleen.